YamahaSynth.com Forums

This is the place to talk about all things related to Yamaha Synthesizers!
  1. Alex
  2. Legacy Yamaha Synths
  3. Saturday, 28 October 2017
I am trying to connect my s90es to my iMac via usb in order to trigger the piano patches on Garageband. I installed the latest driver, set the midi in/out to "usb" and connected the keyboard. The keyboard bed is not triggering sounds from the piano patches, but the other buttons (f1, sf1, track select buttons etc.) are triggering sounds. Also worth noting, I bought the keyboard used so I'm not sure if there's some other special setting I overlooked.

Please Help!
Responses (5)
Bad Mister
Yamaha
Accepted Answer Pending Moderation
When the front panel buttons are triggering notes this is a sure indication that the wrong MIDI Port is being used.

Port 1 deals with the keys and controllers (as you would want if controlling something via MIDI).
Check your Port Setup.

The “latest driver” may not be the one you need... it is always best to state exactly which version of the Driver you are using, so someone offering help can verify you have the right one for your computer and it’s Operating System (which you should also mention) I know it seems like a silly thing but it is what makes this all work... the right driver (not necessarily the latest driver, some times it is the latest, but not always) for the right computer OS.
  1. more than a month ago
  2. Legacy Yamaha Synths
  3. # 1
Accepted Answer Pending Moderation
Ok, thanks for the help!

Under "Utility" -> "Other" I have set ThruPort - 1. The driver I installed is version 1.3.2 for Mac OS. I am also on macOS Sierra, version 10.12.6.
I did notice when on the "remote" mode, the top right of the screen says "ModeA-General Port=4". Do I need to change that to port 1? How would I do that?
  1. more than a month ago
  2. Legacy Yamaha Synths
  3. # 2
Bad Mister
Yamaha
Accepted Answer Pending Moderation
No. The Remote Mode? There is no remote control template for Garageband, why are you using the Remote Mode? I’m confused.
For now set both MODE A and B to OFF, and resist hitting the REMOTE mode...
[UTILITY] > [F4] CTL ASN > [SF4] REMOTE

I’m not a Garageband user but when I mention the S90 ES uses Port 1 to send data, that is not something you get to set in the S90 ES, it’s fixed, that’s the Port it uses. You need that information so that your key presses and controller movements get into your software. So in the software there is a place where you select INPUTs, that is where you want to set it to receive info from the S90 ES on Port 1.

The THRU PORT allows you to send MIDI data from your computer via USB to a MIDI device connected to the S90 ES’s 5-pin MIDI Out. If you have nothing connected you can ignore this setting.
  1. more than a month ago
  2. Legacy Yamaha Synths
  3. # 3
Accepted Answer Pending Moderation
Ah, k. Sorry, I'm really new at this stuff haha.. I set the MODE A and B to OFF.

I also noticed that the KBDTransCh setting under [UTILITY] > [F5] MIDI > [SF1] CH was set to "off." I set it to 1 and it works! Thanks for helping me figure all this stuff out!
  1. more than a month ago
  2. Legacy Yamaha Synths
  3. # 4
Bad Mister
Yamaha
Accepted Answer Pending Moderation
Cool!
  1. more than a month ago
  2. Legacy Yamaha Synths
  3. # 5
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!
2021 © Yamaha Corporation of America and Yamaha Corporation. All rights reserved.