YamahaSynth.com Forums

This is the place to talk about all things related to Yamaha Synthesizers!
  1. Bad Mister
  2. Sherlock Holmes The Voice Firestarter
  3. MONTAGE
  4. Monday, 06 February 2017
There are only two kinds of technology users, those who backup their data and those who have catastrophes...

Make sure you backup each Library, your User Bank, your Songs, all of your data. Performing the firmware update 1.50 will wipe out the Libraries, the User Bank, even the Songs in your Song folder. (I recommend you have a .mid File for each installed Song). You will need to reinstall your Libraries!
(Details: You cannot make a direct backup of your Library data - if you have installed a Library and have that original file, locate it before doing the Firmware Update). If not, use the IMPORT LIBRARY File feature to move the Library data to the USER Bank and then SAVE as "Library file".)

The download includes instructions. Don't forget to download the new version of the Montage Connect (v1.0.2)

Read the documentation twice. Once before performing the update, and then the second time as you perform the update. The actual update is easy, a child could do it. The important thing is to not interrupt the process once it has begun. In the unlikely event you get struck by lightning or your power goes off during the process, you will need to redo the firmware update process, again, when power is restored. If it will not proceed contact your regional Yamaha office... when your power is restored. Otherwise, do not interrupt the firmware update process, and you will be fine.

Because new Performance data has been added, and new features, you may find you have to or you may want to, redo and/or tweak your custom setups. One piece of good news, the new firmware adds the BACKUP FILE (.7XA) which from now on will allow you to place everything in one file (good news for traveling musicians who rent backline Montage's) - you can transfer "your" Montage to the borrowed unit in one operation.

CAUTION
- This updater is only for the MONTAGE synthesizer.
- This updater is to be used at the user's own risk.
- All User memory (Library data, User data, User sample and so on) will be initialized by this updater. Please make sure that you have saved all User data to a USB flash drive before performing this update.
- The unit may become inoperable if the electrical supply is interrupted while running the updater (by disconnecting the AC cord, etc.). If this happens, run the updater again from the first step.
- If the unit does not function after running the updater, please contact your nearest Yamaha service center.
Yamaha Global Gateway
https://www.yamaha.com/countries/
Responses (21)
Accepted Answer Pending Moderation
Hello BM, I have now installed v1.50 with not problems (having hopefully learned the lessons you taught me with v1.20), but I do have what is probably a basic question! I began re-installing the 'User' area with the Bosendorfer Library - no problems, all there. Then I re-installed my User Banks - initially seemed fine, but as I progressed I noticed several Pfs didn't sound, and others missing altogether. Thinking about this, I wonder if one has to re-install the Library from which the original sound was taken before it appears / can be used after an update? That is, they are 'Lending Libraries' which must be in place before I can 'borrow' the sound. I had assumed that the sound was copied complete when I was editing it, and became an independent Performance when stored.

If that is the case, and the Library from which I used a sound has to be in place on the Montage before I can play my modified Pf, then that has fatal implications for my plan to create a number of small Libraries on the USB to get round the limitation of only 8 on the Montage itself.
  1. more than a month ago
  2. MONTAGE
  3. # 1
Bad Mister
Yamaha
Accepted Answer Pending Moderation
Rod,

Congratulations on successfully updating your Montage Firmware.

We see that you are not at all clear on how the Library thing works. Let's try again.

If you understand the Factory Preset PERFORMANCES, they are in a permanent area and are always exactly where they were placed (installed) by the good folks at the Yamaha Factory in Hamamatsu, Japan. You cannot change where they are or anything about them in those locations...

Let's talk about what happens when you recall a Factory Preset PERFORMANCE: its data is copied into an EDIT BUFFER. While in this Edit Buffer, sure, you can EDIT the parameters but you cannot permanently change them where they are in the Factory Set. If you EDIT a Factory Preset PERFORMANCE and you press [STORE] you are offered a place in the USER Bank... one of 640 locations in the USER BANK. It is highly recommended that you reName the Performance to differentiate it from the Factory version which still exists, unchanged!!!

The USER Bank is where you can store changes to the Factory Preset PERFORMANCES. Clear on this? Each AWM2 PART will still "point to" the Waveform and Sample data in the permanent WAVE ROM (installed in Japan). And your files will work in anybody's Montage.

Now lets talk about the LIBRARY area... these are (semi)-permanent version of what the factory did. We say "semi" because you can ultimate DELETE them and redo them but they have the same fixed status as a Factory Preset, with the exceptions that 1) YOU installed them into their locations and 2) you can, in a lengthy process, uninstall/reinstall them. You cannot simply change where they are or anything about them while they are in that Library location (Read Only Memory).

When you simply recall a PERFORMANCE from the Library, it is coped into the EDIT BUFFER. While in the EDIT BUFFER, sure, you can EDIT the parameters but you cannot change them in their original location ... if you EDIT a Library PERFORMANCE and you press [STORE] you are offered a place in the USER Bank. The data will refer ("point to";) to the Waveform Location in the Library data.

If you want to make an actual change to the data in an installed LIBRARY, you must first IMPORT that data from the LIBRARY. Here is the critical bit of information: The act of *IMPORTING* a LIBRARY PERFORMANCE and then editing it, is different from just recalling it and editing it. Let's say that again to stress the importance: IMPORTING a LIBRARY PERFORMANCE to USER is different from just recalling it and editing it.

The act of IMPORTING a program from a Library places it in the USER memory with a special 'FLAG' (this flag tells the Montage that when, and if, you now make a FILE from the USER bank, it will include the WAVEFORMs and SAMPLEs that make it work. The IMPORT LIBRARY function is very important because it allows you to make changes to data you have INSTALLED> By now creating a NEW LIBRARY File.

Okay to fully understand this you need to know WHY does this exist:

I only use the word "INSTALL" when referring to the act of putting data into one of the 8 Library locations.

You are using the word "install" incorrectly. A USER FILE (.X7U) cannot be installed (as I am using the word). Because it cannot be directly moved into a Library.

You can only LOAD a User File (.X7U) to the User Bank.
You can INSTALL a Library File (.X7L) to the a Library location

Install is the act of transferring a FILE to one of the 8 Library locations.

If your goal is to build a "number of small Libraries on the USB to get round the limitation of only 8": First, the number of installed Libraries is fixed at 8. You are not clever enough to circumvent this... :) I'm just trying to get you to understand how the Import Library function works. Try that first.

IMPORT LIBRARY
Press [UTILITY]
Touch "Contents" > "Import Library"
This function will allow you to select data that is already installed in the semi-permanent Library (ROM) memory and move that data to the 640 User Bank (RAM) locations. The significant thing is, unseen by you, the Montage makes a note (flags) the data so that when you create a FILE from this User Bank data it will include the Waveforms and Samples necessary to make an independent FILE.

If, however, you were just to recall a sound from a LIBRARY and edit it, and STORE it to the User Bank, a file made from this USER Bank would not include the Waveforms and Samples, it would simply "point to" the installed Library locations for that data - the Library locations are unique to your Montage (as opposed to your friend's Montage). Quite different. If you now make a File that file will play as long as it is YOUR Montage... but if you were to give that file to a friend with a Montage - they would not be able to play the sounds because some of the PERFORMANCES would not sound. Do you understand why? It's because they do not have your unique listing of Waveforms and Samples in their instrument.

In order to make a file that contains the Waveforms and Samples you must have IMPORTED LIBRARY data... then made the File.

Please read several time until it sinks in... You cannot get around 8 Libraries, with small Libraries. What are you attempting to do???? Or better WHY is this a thing for you to try to do? Trying to get around a limit you don't understand is what is confusing you. STOP. Each Library can contain a maximum of 640 Performances... use them wisely, use them more efficiently.
  1. more than a month ago
  2. MONTAGE
  3. # 2
Accepted Answer Pending Moderation
How can I audition the new performances, where are they. Release notes say to find them in the new 1.50 data list but it appears that they may be scattered throughout-not sure. I wish Yamaha would have PGM numbers on the performance page. This really should be done, trying always to find via CAT search is not convenient. If I know a performance is 421, well....
  1. more than a month ago
  2. MONTAGE
  3. # 3
Bad Mister
Yamaha
Accepted Answer Pending Moderation
They are marked in the DATA LIST booklet with the symbol: *1

/images/Motif_XF/Miscellaneous/Customer/DataList1.png

Please see the Data List booklet...
  1. more than a month ago
  2. MONTAGE
  3. # 4
Accepted Answer Pending Moderation
With new firmware midi problems (exposed in tread here: https://yamahasynth.com/forum/turn-off-keyboard-transmit-channel/latest#filter-sort) on my configuration are solved....I change nothing so I can say that the new firmware solved this kinf of issue.
Thanks yamaha.
Best regards
  1. more than a month ago
  2. MONTAGE
  3. # 5
Bad Mister
Yamaha
Accepted Answer Pending Moderation
Good, because I could not reproduce your issue...
  1. more than a month ago
  2. MONTAGE
  3. # 6
Accepted Answer Pending Moderation
Bad Mister wrote:

Good, because I could not reproduce your issue...


Very good!!! :D
Thanks anyway!
  1. more than a month ago
  2. MONTAGE
  3. # 7
Accepted Answer Pending Moderation
Installed the new firmware, no problems whatsoever. Love the new features. I immediately did a full backup after reloading everything. Such a relief!

I see another unexpected improvement: With the previous firmware I always had a problem with inadvertent repeated characters when typing on the touch screen. While not completely gone, this is now much better than it was. So apparently there is some improved debouncing. Thanks, keep the updates coming :-).

I guess my favorite change is that I can now replace parts without having to redo the splits / transpose etc.
  1. more than a month ago
  2. MONTAGE
  3. # 8
Accepted Answer Pending Moderation
When I purchase my new Montage do I have to backup anything prior to updating the firmware (I will update straight out of the box)
  1. more than a month ago
  2. MONTAGE
  3. # 9
Accepted Answer Pending Moderation
No, no need to backup anything. Everything you have when you get the Montage is in ROM and cannot get lost.
  1. more than a month ago
  2. MONTAGE
  3. # 10
Accepted Answer Pending Moderation
Thanks Stefan
  1. more than a month ago
  2. MONTAGE
  3. # 11
Accepted Answer Pending Moderation
@Andrea

On another thread, this is what I meant when referring to:

https://yamahasynth.com/forum/introducing-montage-os-version-1-5#reply-17530

... for all the pushback from Yamaha about not understanding how things work - it's nice to see that the firmware team at least saw this as a real error:

Fixed a problem in which Zone settings would not be correctly applied by switching Performances.


Seems to fit the problem seen by a few folks changing from a user performance with zone settings on a PART that is unused on the switched part - and still seeing bank/PC messages when switching to the new part.


So your issue seemed to have made it into the firmware release notes as bugs fixed.
  1. more than a month ago
  2. MONTAGE
  3. # 12
Accepted Answer Pending Moderation
Is there a link to the version 1.5 data list? I can only see "MONTAGE6/7/8 Data List V1.10" in the downloads.
  1. more than a month ago
  2. MONTAGE
  3. # 13
Accepted Answer Pending Moderation
Hello BM - thanks for your detailed reply! Also for the reminder earlier that 'Connect v1.02' is also required - I'd overlooked that! A bonus with v1.50 is that if you use an external monitor for Montage, the bright green strip at the bottom of the screen is gone - now a black one, which is easier on the eyes. I very much like the addition of 'Favourites' - easy to do on the fly - and the 'one shot back-up all' facility (which takes about 10 minutes or more depending on your content). Haven't got to grips with the rest of it yet, but looks promising ...

I see your distinction between 'Load' and 'Install' - to me the terms are interchangeable, but we both know what we mean!

I think my main problem is a degree of confusion about 'importing', in that having already imported the Library, I didn't expect to have to then 'import' a sound from that Library as well. Your explanation clears that up - the Library is still there to be linked to (like pre-sets) so it is necessary to break that link in order to produce an independent sound that will work whether the Library is there or not. To avoid confusion in my own mind I think of that second step as 'converting' from a Library file to a User file. Would you be kind enough to give me a step-by-step please? Say I have selected a Performance from a an imported Library file, and wish to convert it into a User file for permanent editing ...

As to why I want several smaller Libraries, it is necessary to understand I'm not interested in music so much as the sounds themselves, so I need those to be arranged in a logical manner in Categories - and preferably Sub-categories as well (eg: solo, duo, section, ensemble) though that seems unlikely on Montage. There are 16 Categories on Montage, so I would have expected 16 Libraries to match the 16 User areas. Failing that, the plan was to keep my Libraries on a USB, and swap them as required so that the Montage never had more than 8 loaded (or installed! - couldn't have anyway) but I had the sounds I wanted easily available. I haven't quite worked out how to do that - I vaguely supposed to save a newly created small Library to USB, then delete that Library from Montage. It's a bit cumbersome in that I have to save and delete every time (I think) but should be workable. I have not yet looked at 'Connect' as to what role that can play in any of this - I'm a slow 'worker' and get distracted very easily, I'm afraid.

Hope to see a step-by-step for the Library to User conversion - and thank you for your time ... stay well ...
  1. more than a month ago
  2. MONTAGE
  3. # 14
Accepted Answer Pending Moderation
Jeremy wrote:

Is there a link to the version 1.5 data list? I can only see "MONTAGE6/7/8 Data List V1.10" in the downloads.


The data list and new features documentation are included with the firmware update. Each firmware update of late has followed this model where the documentation is updated in the firmware ZIP file without necessarily updating the downloads list with the latest documentation-only PDFs.

Complete firmware file list:

8N70OS_.PGM --------------- Firmware image
montage_en_dl_d0.pdf ----- Updated Data List (Last page showing "Published 01/2017 MW-D0";)
montage_en_nf_c0.pdf ----- New Features Document (basically a reference manual or owner's manual supplement)
montage_de_nf_c0.pdf ----- New Features Document, more languages ...
montage_es_nf_c0.pdf
montage_fr_nf_c0.pdf
montage_it_nf_c0.pdf
montage_ja_nf_c0.pdf
montage_ko_nf_c0.pdf
montage_nl_nf_c0.pdf
montage_pt_nf_c0.pdf
montage_ru_nf_c0.pdf
montage_zh_nf_c0.pdf
v150_Readme_en.txt ------- Changes summary, update instructions - text file
v150_Readme_ja.txt
  1. more than a month ago
  2. MONTAGE
  3. # 15
Accepted Answer Pending Moderation
Thanks Jason, overlooked that.
  1. more than a month ago
  2. MONTAGE
  3. # 16
Accepted Answer Pending Moderation
Successful update to new firmware version 1.5.
I read someone said that they have trouble with some voices without sounds after update the firmware 1.5 Please reload Your Users Files after updating and it will be fine.
  1. more than a month ago
  2. MONTAGE
  3. # 17
Accepted Answer Pending Moderation
Hello Tho - good for the update! Don't forget ;Connect' v1.02 to go with it - the new version installs over the top of the old. 'Twas I that lost some sounds (surprise!) - because I did not re-load the Libraries first, and then the User Bank. So some of my sounds that had been produced from Library Performances failed to work without their Libraries present. BM explained this, and is currently helping me to avoid this in future. For the problem I have now, I propose to re-install the Libraries (just started) and see if that works ...
  1. more than a month ago
  2. MONTAGE
  3. # 18
Accepted Answer Pending Moderation
Also don't forget to turn off the "Blur" and "Animations" which are set by default to "ON". This will speed up your OS considerably.
  1. more than a month ago
  2. MONTAGE
  3. # 19
Accepted Answer Pending Moderation
Thanks!
  1. more than a month ago
  2. MONTAGE
  3. # 20
  • Page :
  • 1
  • 2


There are no replies made for this post yet.
Be one of the first to reply to this post!
2018 © Yamaha Corporation of America and Yamaha Corporation. All rights reserved.