YamahaSynth.com Forums

This is the place to talk about all things related to Yamaha Synthesizers!
  1. damon
  2. reface
  3. Saturday, 17 October 2020
Hey Yamaha reps!

When I login to sound mondo with my Reface dx plugged in via usb (of course) I get an error msg. It says something to the effect that "a security breech has ocurred and someone has tried to bypass the security". I have, in fact had identity theft recently (AT&T, etc.) but would really like to get this fixed. I've been a Yamaha customer for many years (R6 bike, P121 electric piano, reface dx etc,) and bought my reface with the idea that I would be using soundmondo.

Can somebody help me get this resolved so I don't have to start making millions of phone calls? (I live in California and have had to speak to the guys in Orange county on ocassion).

I've already exhausted all the regular avenues - i.e. redoing my password, updating profile etc. I really need someone to point me in the right direction on this.

Thanks for any help in advance!

D. Knight
Responses (1)
Accepted Answer Pending Moderation
... since Yamaha recommends using Chrome, I'm going to make an assumption that's what you're using below ...

The security warning - if it implies there has been a breach - is overly chicken-little. When you do not have a website configured to accept SysEx (MIDI full control) - you are telling Chrome to deny web pages that try to access your MIDI hardware through SysEx. Soundmondo uses SysEx to "talk" to your reface. Therefore, when you go to Soundmondo from Chrome - Chrome will be requested by Soundmondo to access your reface using SysEx commands. Upon seeing this, Chrome will say "nope! you can't do that" in response to Soundmondo's request if your browser has not placed Soundmondo on the list of sites that accept "full MIDI control".

This thread has pictures of how to recognize your browser is misconfigured and does not allow Soundmondo the rights to access your MIDI hardware:

https://www.yamahasynth.com/ask-a-question/soundmondo-issue

The thread also discusses how to fix this.

This error, if my assumption of what you're seeing is correct, has nothing to do with your Soundmondo account. It has everything to do with your browser configuration and all within your power to correct.

This is one of the many reasons why using a web browser for MIDI is not "plug and play" and requires the end user to deal with a "mess" of nonsense in order to make it actually work. Yamaha hasn't exactly helped the situation either since the javascript code on their end doesn't do absolutely everything it could in order to deal with some of these failure modes. And they even add some failure modes on their own (i.e. bugs) that I know affect MODX and Montage. Not sure about Reface.

Right now you're just dealing with the configuration burden on your end. This isn't anything Yamaha could do much more about except for detect SysEx (full MIDI control) is not configured properly and present you with some pictures of where you need to go to fix the problem in chrome. Something that would/could perhaps grow stale and need updating as Chrome updates. At any rate - you're mostly dealing with something, at this point, that's a problem or weakness with WebMIDI as it exists today.

These problems in total are part of why, recently, I've mentioned that the iOS Soundmondo experience would be less problematic. That doesn't help if you do not own an iOS device.
  1. one week ago
  2. reface
  3. # 1
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!